Return air vents not returning air


  #1  
Old 01-24-17, 04:02 PM
A
Member
Thread Starter
Join Date: Dec 2016
Location: United States
Posts: 46
Upvotes: 0
Received 0 Upvotes on 0 Posts
Return air vents not returning air

Hi everyone! I had a new furnace professionally installed about a year ago. This year I am finishing my basement. There are two return air vents in the ceiling of the room I'm finishing but they don't seem to be doing anything - there's zero air pull coming from them when the fan is running. The upstairs return vents are working (I tested by putting a plastic bag up to them and it pulls it in). So why would the basement ones not be? Are there things I can check without hiring a professional to come look at it? And how critical is it that these work? I'm not sure if they ever have. There are two supply vents in the same room along the floor and those are fine - I can feel warm air coming out of those.
 
  #2  
Old 01-24-17, 04:34 PM
Marq1's Avatar
Member
Join Date: Sep 2016
Location: USA MI
Posts: 9,745
Received 1,210 Upvotes on 1,098 Posts
Have you confirmed that the ducts are physically connected to the main return line?

The new furnace was installed but did they do anything to the duct work? Maybe it was that way from the beginning?
 
  #3  
Old 01-26-17, 01:34 PM
HVAC RETIRED's Avatar
Member
Join Date: May 2008
Location: Wisconsin USA
Posts: 664
Upvotes: 0
Received 0 Upvotes on 0 Posts
If any combustion vented to a chimney you usually don't want returns in basement...may be disconnected on purpose...?
 
  #4  
Old 01-27-17, 02:33 AM
Marq1's Avatar
Member
Join Date: Sep 2016
Location: USA MI
Posts: 9,745
Received 1,210 Upvotes on 1,098 Posts
you usually don't want returns in basement
Know that you mention it I dont have any return ducts in the basement!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: