Danby wine/beverage fridge not cooling

Reply

  #1  
Old 11-26-17, 12:19 AM
S
Member
Thread Starter
Join Date: May 2006
Location: Vancouver, BC, Canada
Posts: 178
Received 0 Votes on 0 Posts
Danby wine/beverage fridge not cooling

I noticed today my 3yr old Dandy wine/beverage fridge stopped working. The inside of the fridge was actually quite warm, I am assuming because the compressor constantly stays on and is super hot. I checked the coils and everything seemed clean. The fan next to the compressor also seemed fine and turns on. I removed the starter relay and opened it up and did a quarter turn on the disk thinking it might help, but it didn't.

Many ideas on what could cause the fridge not to cool?
 
Sponsored Links
  #2  
Old 11-26-17, 01:59 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,794
Received 1,193 Votes on 1,104 Posts
Is the compressor running and warm ?
If yes and no cooling..... it sounds like low on refrigerant.
 
  #3  
Old 11-26-17, 04:39 AM
Marq1's Avatar
Member
Join Date: Sep 2016
Location: USA MI
Posts: 6,698
Received 396 Votes on 370 Posts
Ive got one of these, in fact the first one would not cool properly was replaced with the current one.

They are not a high quality unit I would not spend a whole lot on repairs.
 
  #4  
Old 11-26-17, 11:16 AM
S
Member
Thread Starter
Join Date: May 2006
Location: Vancouver, BC, Canada
Posts: 178
Received 0 Votes on 0 Posts
I took the back of the fridge apart and noticed in the drip tray there was a green residue, assuming dried coolant. Is it normal for fridges to leak a little coolant over time or is this what is causing the cooling problem, eg. Coolant leak? Can coolant be easily added? Just hate to throw out an overwise good fridge that cost over $1500.
 
  #5  
Old 11-26-17, 11:50 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,794
Received 1,193 Votes on 1,104 Posts
The green residue is condensation that has run over the copper lines and corroded the copper. It's a side effect of water and copper.

The uncontained refrigerant is a gas so it will leave no trace other than sometimes an oily residue as there is some oil in the system for the compressor. The systems are not designed to be recharged. There are no fittings to attach to. A fitting can be added and the system could be recharged but the leak would need to be found first. The cooling system is a sealed loop and should never need recharging.

Those units are pretty tightly built and it can be difficult finding the leak and even more difficult to fix. You could probably find an HVAC tech to work on it but be prepared to spend several hundred dollars on a repair.
 
  #6  
Old 11-26-17, 01:21 PM
S
Member
Thread Starter
Join Date: May 2006
Location: Vancouver, BC, Canada
Posts: 178
Received 0 Votes on 0 Posts
Any idea on how I test the start relay?
 
  #7  
Old 11-26-17, 01:22 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,794
Received 1,193 Votes on 1,104 Posts
I thought you said the compressor was running ?
 
  #8  
Old 11-26-17, 03:18 PM
S
Member
Thread Starter
Join Date: May 2006
Location: Vancouver, BC, Canada
Posts: 178
Received 0 Votes on 0 Posts
Well it feel like it is. Makes slight noise and has a low vibration. And it gets super hot. Oddly the coils under the fridge remain cold.
 
  #9  
Old 11-26-17, 03:39 PM
S
Member
Thread Starter
Join Date: May 2006
Location: Vancouver, BC, Canada
Posts: 178
Received 0 Votes on 0 Posts
I used a multimeter to test the relay. On the lowest resistance level, I probed the two connection points on the back, labelled S and M. The readings were all over the place, as high as 160 and as low as 4. Any ideas?
 
  #10  
Old 11-26-17, 05:48 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,794
Received 1,193 Votes on 1,104 Posts
You can't check the relay in place. You'd need to pull it out. If the compressor is humming..... it's running, There are two copper lines coming off the compressor. One should be hot and the other cold. If you have that the compressor is positively running.
 
  #11  
Old 11-27-17, 03:06 AM
Marq1's Avatar
Member
Join Date: Sep 2016
Location: USA MI
Posts: 6,698
Received 396 Votes on 370 Posts
Just hate to throw out an overwise good fridge that cost over $1500.
Mine is just a small 100 can unit think we paid couple hundred, didn't think they made any in that price range!
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: