Go Back  DoItYourself.com Community Forums > Household Cleaning, Kitchen Appliance Service and Repairs > >Electric< Large Kitchen and Home Appliances
Reload this Page >

Whirlpool dishwasher - replaced the diverter motor, now clicking all the time

Whirlpool dishwasher - replaced the diverter motor, now clicking all the time

Reply

  #1  
Old 01-24-19, 05:55 PM
B
Member
Thread Starter
Join Date: Mar 2005
Location: Frisco, TX
Posts: 86
Received 0 Votes on 0 Posts
Whirlpool dishwasher - replaced the diverter motor, now clicking all the time

Have a wdt790saym1 dishwasher which developed a leak at the diverter motor seal. Seeing that the diverter motor was also making sort of a groaning noise when it would start running, I bought the seal (3rd party part, as Whirlpool does not sell this separately anymore) as well as the new motor.

Now - the original part for the diverter motor was W10476222. After some research, it seemed like the replacement part for this is W10537869, so that is what I got. Plugged it all in etc, no leak, however...

The diverter motor is making a loud clicking noise every 6 seconds or so. I suspect this is not right?

I watched some YouTube videos on how to reset the dishwasher; some places say that I might need to put it into diagnostics cycle. This dishwasher does not have a LCD.

Any ideas on what I should do?
 
  #2  
Old 01-24-19, 06:30 PM
B
Member
Thread Starter
Join Date: Mar 2005
Location: Frisco, TX
Posts: 86
Received 0 Votes on 0 Posts
I should add - the dishwasher seems to run just fine; it is going through the cycle right now. I might be imagining all this LOL but I don't think it was clicking as much before?

I know it's the diverter motor because if I hold my finger on it, I feel the vibration.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: