Help with my Paslode finish nailer

Reply

  #1  
Old 06-03-18, 12:00 PM
Y
Member
Thread Starter
Join Date: Jun 2018
Location: Usa
Posts: 2
Received 0 Votes on 0 Posts
Help with my Paslode finish nailer

have the same problem with Paslode finish nailer and framed nailer. Cleaned and greased put new fuel cells and they donít want to fire. I think thereís a problem with the cell compartment because doesnít want to close right. I tough there were only two sizes of fuel cells. You can here the fan going when I put battery but ones I press down to fire the fuel cell compartment opens. Please help I donít know what am I doing wrong
 
Sponsored Links
  #2  
Old 06-03-18, 12:11 PM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Location: USA
Posts: 26,024
Received 677 Votes on 626 Posts
The finish nailer takes a yellow fuel cell... the framing nailer takes a red cell. Could that be part of the problem? Also the older guns were a different size than some of the newer ones.
 
  #3  
Old 06-03-18, 01:58 PM
Y
Member
Thread Starter
Join Date: Jun 2018
Location: Usa
Posts: 2
Received 0 Votes on 0 Posts
Yes, Iím using yellow for the finish nailer and red for the framing. I only saw those two different at Loweís. Paslode brand and they are supposed to fit both of my nailers. Plus they are just two sizes yellow small, for finish nailer and red bigger size for framing nailer.
 
  #4  
Old 06-04-18, 12:21 PM
W
Member
Join Date: Feb 2006
Location: USA
Posts: 6,709
Received 19 Votes on 18 Posts
Check the bottom of the fuel cell compartment for foreign objects.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: