Roses growing but few buds


  #1  
Old 07-09-17, 07:40 AM
A
Member
Thread Starter
Join Date: Oct 2001
Location: USA
Posts: 283
Upvotes: 0
Received 0 Upvotes on 0 Posts
Question Roses growing but few buds

I have three lavender patio roses in planters on my south-facing patio. I believe they get the required 6 hrs sun. I water each day (very hot temps in the midwest).
The bush is putting out long, thin stems which are green, but few blooms (maybe one at the very end of the stem).

Any ideas what could be causing this to occur?
 
  #2  
Old 07-09-17, 07:46 AM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Posts: 29,648
Received 1,644 Upvotes on 1,472 Posts
Could be too much nitrogen or not enough. Are you fertilizing at all? Have you deadheaded the old blooms?
 
  #3  
Old 07-09-17, 05:33 PM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 28,592
Received 1,708 Upvotes on 1,525 Posts
Did you prune at the end of the season last year or early in the season this year?
 
  #4  
Old 07-10-17, 08:14 AM
W
Member
Join Date: Feb 2006
Location: USA
Posts: 6,926
Received 60 Upvotes on 52 Posts
Roses

Deer love the new, tender growth just ahead of the blooms. Look for severed shoots.
 
  #5  
Old 07-17-17, 07:17 AM
Y
Member
Join Date: Mar 2007
Location: Oregon
Posts: 922
Received 22 Upvotes on 21 Posts
How long have you had them.....are they bush roses ?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: