Gas oven wont heat up, Pilot is on


  #1  
Old 06-16-19, 12:39 PM
O
Member
Thread Starter
Join Date: Jun 2019
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
Gas oven wont heat up, Pilot is on

Hi everyone, my very old Edison in-wall gas oven stopped working about a week ago and I cannot figure out the issue. The pilot light is on, but when I turn the knob to start the oven I dont hear/smell the gas coming out of the burner like I used to, and the burner wont light. The oven has a timer and I have the controls set to Manual Mode, oven worked fine last week but it just stopped turning on last night. I have attached pictures of the oven and the inside parts, anyone have any advice?

Name:  o1.jpg
Views: 162
Size:  35.6 KB

Name:  o2.jpg
Views: 117
Size:  48.3 KB

Name:  o3.jpg
Views: 129
Size:  83.7 KB

Name:  o4.jpg
Views: 103
Size:  45.3 KB

Name:  o5.jpg
Views: 105
Size:  31.4 KB
 

Last edited by PJmax; 06-16-19 at 03:11 PM. Reason: reoriented/resized pictures
  #2  
Old 06-16-19, 03:13 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,133
Received 1,522 Votes on 1,405 Posts
Welcome to the forums.

I can't find the model number and I don't recognize the unit.
Is there just one control for both ovens ?
One burner for both ?

I could use a close up picture of just the pilot burner.
 
  #3  
Old 06-16-19, 06:07 PM
O
Member
Thread Starter
Join Date: Jun 2019
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
More Details...

Hi PJmax,

Thanks for the reply, the oven has one control and one burner for both ovens. See attached for a close up picture of the pilot, I turned off the gas supply to the pilot to take the picture, but the pilot is still working.

Name:  p1.jpg
Views: 96
Size:  45.0 KB
 

Last edited by PJmax; 06-16-19 at 10:00 PM. Reason: resized/labeled picture
  #4  
Old 06-16-19, 10:03 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,133
Received 1,522 Votes on 1,405 Posts
What do you need to do to light the pilot ? Hold some button in ?

The part with the red arrow sits in the flame and tells the gas valve that the pilot is lit.
Since the pilot is staying lit..... it's probably ok

I see a red wire on the gas valve. That may mean the valve is electrically opened.

I'm still looking for information on this oven.
The model looks like.... QKO-161.
 
  #5  
Old 06-18-19, 01:16 PM
O
Member
Thread Starter
Join Date: Jun 2019
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
The pilot is lit by turning the gas back on to the appliance (I have a valve in the basement to shut off gas to the oven) and putting a lighter up to the pilot. The model is indeed QKO-161 and I have not been able to find any information about this oven either.
 
  #6  
Old 06-19-19, 08:52 AM
B
Member
Join Date: Jun 2002
Location: Northern Minnesota
Posts: 1,704
Received 7 Votes on 5 Posts
I had an old stove with a similar pilot and after a few decades the oven wouldn't light even though the pilot was lit.

Turns out it was that white fuzz on the pilot, apparently something wasn't getting quite hot enough.

Try turning off the pilot and let it get nice and cold then use an old toothbrush or something and brush the fuzz away.

Worked for me.
 
  #7  
Old 06-19-19, 07:48 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,133
Received 1,522 Votes on 1,405 Posts
I placed a red arrow in the picture. That is some type of thermostatic sensor/thermocouple. The pilot flame heats that and that allows the gas valve/thermostat to open and let the burner light. Cleaning that may help but is doubtful.

So far...... I have not found any information on the oven. I am still looking.
 
  #8  
Old 06-21-19, 07:05 AM
O
Member
Thread Starter
Join Date: Jun 2019
Location: United States
Posts: 4
Received 0 Votes on 0 Posts
Thanks for the advice Baldwin. I cleaned up the thermocouple with an old toothbrush and got the white stuff off, unfortunately that did not resolve the issue and the oven will still not start when the knob is turned.
 
  #9  
Old 06-27-19, 07:17 PM
M
Member
Join Date: Aug 2014
Location: USA
Posts: 33
Received 0 Votes on 0 Posts
You need to take some pics of the controls behind the panel. The timer, oven control, etc. The two leads connecting to the valve probably open it in a call for oven gas. We need to see where and how they are connected. Also where the thermocouple is connected
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: