Kenmore stove: an easy ignition Q

Reply

  #1  
Old 07-22-19, 07:41 PM
C
Member
Thread Starter
Join Date: May 2016
Location: usa
Posts: 53
Received 0 Votes on 0 Posts
Kenmore stove: an easy ignition Q

I have a Kenmore gas stove/oven in one of my rentals and the oven is fine but none of the top burners will fire up. It's electric ignition and the igniters work and gas comes out but none will light.

I'm sure this is due to grease in the burner unit. I cleaned them with a toothbrush and degreaser but didn't help.

Isn't there a hole from the igniter to the area where the gas is? How would I clean this out?

Thanks!!

Chuck
 
Sponsored Links
  #2  
Old 07-22-19, 11:36 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,855
Received 1,204 Votes on 1,114 Posts
Yes..... there is a single hole from the orifice area to the igniter.
You should be able to see it near the igniter. You can use a paper clip or needle to clean it.
 
  #3  
Old 07-23-19, 08:51 PM
C
Member
Thread Starter
Join Date: May 2016
Location: usa
Posts: 53
Received 0 Votes on 0 Posts
Thanks, PJ. I will try it tomorrow evening.
 
  #4  
Old 07-28-19, 07:33 PM
C
Member
Thread Starter
Join Date: May 2016
Location: usa
Posts: 53
Received 0 Votes on 0 Posts
Thank you very much...They all work now!
 
  #5  
Old 07-29-19, 01:31 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,855
Received 1,204 Votes on 1,114 Posts
Good job on the cleaning. Name:  thumb.jpg
Views: 23
Size:  1.6 KB
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: