Carrier Furnace Comfort 80 Model . Error 33 goes to Error 13


  #1  
Old 02-25-18, 08:00 AM
C
Member
Thread Starter
Join Date: Feb 2018
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Carrier Furnace Comfort 80 Model . Error 33 goes to Error 13

I have an old carrier 80 comfort gas furnace heater. I am not sure how old that is since I got a new house and I am a new homeowner.

I have started to do DIY fixes lately. The AC broke down last year and it was under warranty and it took 4 weeks for the repairman to schedule and repair my AC.

I did a DIY fix for error 21 (secondary voltage), I changed the blade fuse and it worked ($3 automotive fuses). Now I have understood decoding error codes and thanks to this forum and YouTubers in helping me out.

Problem:
My heater has stopped working lately. I never used it for a while and it was working a week ago. After the heat is on on thermostat, the blower keeps running (auto mode) for long hours with no heating.

I had a bad filter which I removed it and installed a new one. Thereafter, I see the error code as 33 and after few minutes it changes to 13 and is stuck there for indefinite hours.

Decoding the errors, I check various sensors. The end wire connections (quick disconnect) on switches are crimped so it was difficult to take out them and measure continuity. Anyways, i checked for two things
(1) Continuity with the end wires still connected
(2) End voltages while the blower was running

I have checked:
(1) Main limit switch which has a special case behind the gas regulator
(2) Two manual reset limit switches which are on side brackets of four flame burner (either side)
(3) Draft safeguard switch which is on the exhaust Flue gas

I checked for continuity - ALL GOOD
I checked for voltages across the end connection and checking for one end by grounding the other end of meter - ALL SHOWS 0.0 V (This doesn't change even after clicking manual red limit switches)

It do not have good knowledge of their wiring but my intuition says these safety switches much be in series so any switch can break the entire circuit.

It looks like the safety circuit is not getting 24V supply since Blower ON test showed 0 V across all switches.

Since Error 33 goes to error 13, i kept the flower running for 3-4 hours and haven't seen any changes in its error status.( I through it should auto-reset after 3 hours)

To clarify, the ignitor never gets hot, no flames, and the inducer motor also don't run as well.

I am stuck at this point and need your expertise to Troubleshoot from this point.

Sorry for the long post, I am new to this forum and this is my first post.
 
  #2  
Old 02-25-18, 03:02 PM
C
Member
Thread Starter
Join Date: Feb 2018
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Problem Solved

Had to replace 3A blade fuse. The voltage accross W(Heat) and C (common) was 6V. (Should be 24V). Replacing the fuse helped solving the problem.

Following references helped a lot.

https://arnoldservice.com/gas-electr...-simplified-2/
https://arnoldservice.com/problem-dr...will-not-open/
 
  #3  
Old 02-25-18, 03:37 PM
R
Member
Join Date: Oct 2016
Posts: 2,183
Received 199 Upvotes on 181 Posts
What caused it to blow? Was the fuse open or closed?
 
  #4  
Old 02-25-18, 04:06 PM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 6,532
Received 95 Upvotes on 88 Posts
It is unlikely that a low voltage fuse is causing a high limit trip

Are you using a 25 dollar highly restrictive air filter?
Do you have a filter at the intake grill and another at the furnace?

It could also be a dirty evaporator coil.
It is often easy to view the entering air side of the coil with horizontal applications.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: