Hot surface ignitor question

Reply

  #1  
Old 04-04-18, 03:43 PM
C
Member
Thread Starter
Join Date: Apr 2018
Location: Usa
Posts: 1
Received 0 Votes on 0 Posts
Hot surface ignitor question

I have a Carrier Weathermaker 9200. It was not working and had code 34 that I narrowed down to the HSI(Hot Surface Igniter) So I replaced it and the furnace fired right up and is working. The only thing is the HSI is staying red hot while the gas furnace is on. Is that normal? I would think it would click off after the flame is lit. It does turn off normally when the thermostat reaches temp and clicks off when furnace is not running.
Thanks,
Chris

 
Sponsored Links
  #2  
Old 04-04-18, 04:56 PM
R
Member
Join Date: Oct 2016
Posts: 1,873
Received 103 Votes on 97 Posts
No, that isn’t normal. Have you confirmed it’s constantly getting power?
If so that’s what killed the old one.
 
  #3  
Old 04-04-18, 05:36 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,139
Received 1,113 Votes on 1,033 Posts
Welcome to the forums.

Post the model number of the furnace. It can be found inside on the side wall near the burner. Post the part number off the control box too.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: