Gas furnace starting issue


  #1  
Old 11-17-18, 01:52 PM
R
Member
Thread Starter
Join Date: Nov 2018
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Gas furnace starting issue

Hello,
Yesterday my furnace (carrier crusader) stopped working(nothing changed except I cleaned air filter last week), I tried turning off the power switch of the furnace, switched on about a minute later and increased the thermostat temperature, then it worked.

Furnace runs until it reaches the set temperature and shuts off,which is fine, but it doesn't start itself when room temperature drops after some time.

Which part is the culprit in this case ? What do you suggest either to replace part or it can be cleaned /repaired?

It looks like every time I have to put temperature atleast 6 degree more,then furnace starts normally. It was not the case earlier.
 

Last edited by Ron81; 11-17-18 at 03:14 PM.
  #2  
Old 11-17-18, 03:36 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,710
Received 4,105 Upvotes on 3,687 Posts
If you have to set the thermostat over the set temperature to make the furnace run....then that would indicate a thermostat problem.

Your furnace may have a control board that logs faults. Usually if it does there will be a sight glass in the blower door to look in and see the fault LED.
 
  #3  
Old 11-17-18, 08:35 PM
R
Member
Thread Starter
Join Date: Nov 2018
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks for your response, LED is constant red as long as furnace has power.

I changed the battrey in thermostat yesterday but no luck. Should I go for new thermostat or anything needs cleanup/replacement in the furnace
 

Last edited by Ron81; 11-17-18 at 09:16 PM.
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: