Ceiling fan light fixture only works on high speed


  #1  
Old 08-05-17, 06:14 PM
F
Member
Thread Starter
Join Date: Aug 2017
Location: USA
Posts: 5
Received 0 Votes on 0 Posts
Ceiling fan light fixture only works on high speed

Hello all,

I had a new Hunter flush mount ceiling fan with a light fixture installed last week by a journeyman electrician. He installed a new box that was fan rated but the problem is that the light won't work unless the fan is on high speed. I have a single wall switch that operates both the fan and the light and the fixture itself has 2 chains that operate the fan and light separately. He also installed a similar Hunter fixture in another bedroom that doesn't exhibit this problem. He's at a loss to figure out what is going on. Any ideas?

Thanks for any help.
 
  #2  
Old 08-05-17, 10:25 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 61,837
Received 1,476 Votes on 1,364 Posts
Welcome to the forums.

Knowing Hunter fans.... either the plug and socket where the switches are located is not plugged in solidly or it's forced in backwards.

You can remove the three screws that hold the light up and the switch housing to the motor unit to check it out without removing the entire fan from the ceiling.

Name:  hunter.jpg
Views: 565
Size:  21.1 KB
 
  #3  
Old 08-07-17, 02:05 PM
F
Member
Thread Starter
Join Date: Aug 2017
Location: USA
Posts: 5
Received 0 Votes on 0 Posts
Thanks for the response. I'll pass it along to my electrician.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: