snowblower seized

Old 01-17-18, 10:28 AM
digraph's Avatar
Thread Starter
Join Date: Apr 2005
Location: South Shore, Boston, MA
Posts: 62
Upvotes: 0
Received 0 Upvotes on 0 Posts
snowblower seized

My 25/30 year old, second hand snowblower just gave up the ship. I'd used it since '08. It had worked without problem on a few snows earlier this year. Today I replaced the auger belt. Started it up, cleared the walk for about 10 minutes, and then it started to smoke. I shut it down, walked it back to the house and then I couldn't turn the crankshaft at all, both from the rope or the pulley side.

I let it cool all the way down, removed the spark plug, and still no movement from the engine.

Any quick ideas?
Old 01-17-18, 11:31 AM
BFHFixit's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jun 2007
Location: USA.
Posts: 1,511
Upvotes: 0
Received 0 Upvotes on 0 Posts
Pull the belt off and see if the engine will go.
Old 01-17-18, 11:36 AM
Join Date: Jan 2013
Location: U.S.A.
Posts: 1,902
Received 73 Upvotes on 66 Posts
The only easy one I have is to remove the belt(s) from the engine, so you are 100% positive that it's uninhibited, and see if the engine turns then. Sounds though like she might be done, so just depends if you want to tear it down and see if it's salvageable, see what you can find as far as an engine replacement, or jump to a complete machine replacement. Before tearing into or replacing the engine though I would carefully inspect the machine itself, the bearings that carry the auger, everything, and make sure it's worth that kind of investment.
Old 01-17-18, 01:54 PM
Norm201's Avatar
Join Date: Sep 2013
Location: United States
Posts: 10,971
Received 729 Upvotes on 644 Posts
Was the crank case full of oil? sounds simple but are you sure?

Thread Tools
Search this Thread
Ask a Question
Question Title: