Jeep Wrangler issue please help

Reply

  #1  
Old 04-10-19, 10:15 AM
J
Member
Thread Starter
Join Date: Dec 2018
Posts: 4
Received 0 Votes on 0 Posts
Jeep Wrangler issue please help

I have a 2006 Jeep Wrangler 2.4 liter manual transmission. Over the winter the check engine light came on, and from time to time the engine would sputter when accelerating. The engine code indicated a bad catalytic converter or O2 censor. I took it in and it was determined that the converter was bad, so I had it replaced. The sputtering stopped. 2 weeks ago the sputtering upon accelerating started again, but no check engine light came on. I took it back to the mechanic and they checked the converter, but there wasn't any issues with it. They, too, are baffled by the sputtering, since no code is being thrown. I thought maybe the TPS was bad, but that would throw a code. 02 censor, maybe? Nope! That would throw a code. Spark plugs? Nope! The misfiring would throw a code! I dumped a bottle of Lucas gas treatment in it, which helped for a day, but today it sputtered again. And I noticed that it gets worse when the engine is heated up. Any idea's? Thank you.
 
Sponsored Links
  #2  
Old 04-10-19, 10:25 AM
M
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 47,663
Received 321 Votes on 285 Posts
When was the last time the fuel filter was changed?
 
  #3  
Old 04-10-19, 10:32 AM
J
Member
Thread Starter
Join Date: Dec 2018
Posts: 4
Received 0 Votes on 0 Posts
Not sure. I bought the jeep last April.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: