New cap on coolant reservoir and steam still escaping...

Reply

  #1  
Old 04-12-19, 01:18 PM
A
Member
Thread Starter
Join Date: Sep 2015
Location: United States
Posts: 139
Received 0 Votes on 0 Posts
New cap on coolant reservoir and steam still escaping...

I turned the new cap until it clicked and steam is still escaping, causing the temp to rise.

The reservoir isn't that old...options?


2001 Ford Taurus
 
Sponsored Links
  #2  
Old 04-12-19, 01:26 PM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 23,781
Received 638 Votes on 588 Posts
Have you confirmed that you got the correct cap? Is the vehicle overheating? If it is the steam escaping is the cap doing what it should?
 
  #3  
Old 04-12-19, 01:32 PM
A
Member
Join Date: Jan 2013
Location: U.S.A.
Posts: 2,079
Received 67 Votes on 61 Posts
With a gas cap, yes, you typically turn it until it clicks. With a radiator cap you will need to press down on it a bit and turn it until it stops. If it's cooled down enough by now that you can safely remove it, look at the bottom of the cap and the top of the radiator neck and you will see the stops.
 
  #4  
Old 04-12-19, 01:35 PM
A
Member
Join Date: Aug 2015
Location: USA
Posts: 592
Received 19 Votes on 18 Posts
if the engine is overheating may also have an issue somewhere else the caps are designed to vent at certain pressure could also see about having the coolant system pressure tested to check cap and reservoir.
 
  #5  
Old 04-12-19, 02:01 PM
A
Member
Thread Starter
Join Date: Sep 2015
Location: United States
Posts: 139
Received 0 Votes on 0 Posts
The brand new cap clicks but does not turn until it stops.
 
  #6  
Old 04-12-19, 03:41 PM
A
Member
Join Date: Jan 2013
Location: U.S.A.
Posts: 2,079
Received 67 Votes on 61 Posts
Ah, sorry about that. I must be having an old man sort of day because I was thinking radiator, but see now that it clearly says reservoir. So now that I'm on track, assuming that the coolant level is correct, I would be thinking radiator cap or thermostat, and the quickest path is probably to do as Alan suggested and have the system pressure checked. Yes, it will cost a few bucks, but the alternative is to keep replacing parts until you stumble across the right one. Does it have an electric fan, and is the fan working? Is/are the belt(s) in good shape and tight?
 
  #7  
Old 04-13-19, 10:50 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,591
Received 11 Votes on 8 Posts
Ashley, you give us very little information.
1. engine is overheating, right?
2. what engine is it? 4cyl, 6 cyl?
3. do fans come up to cool it down?
4. do you have radiator cap or it is expansion reservoir only? I am yet to see that one to have cap that won't stop turning but who knows..
5. Very important. Remove cap on cold engine, take flash light and shine light inside the reservoir, through the cap neck. What does coolant look like? Does it have oil or milkshake in it? Does i have foam layer floating atop of coolant?
 
  #8  
Old 04-13-19, 02:53 PM
A
Member
Thread Starter
Join Date: Sep 2015
Location: United States
Posts: 139
Received 0 Votes on 0 Posts
Six cycliner 2001 Taurus and the temp gauge rises after driving a short distance. Here's a video subsequent to that fairly short drive...

https://www.youtube.com/watch?v=ngJglMvLiak
 
  #9  
Old 04-14-19, 06:41 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,591
Received 11 Votes on 8 Posts
Do the cooling fans come up or not?
Otherwise, could be as simple as crack in the canister neck or anything else mechanical and electrical, blown head gasket including.
Did you look inside the canister to evaluate coolant condition?
 
  #10  
Old 04-14-19, 07:22 AM
H
Member
Join Date: Nov 2012
Location: USA
Posts: 1,763
Received 97 Votes on 86 Posts
Originally Posted by AshleyQuick
New cap on coolant reservoir and steam still escaping...
I turned the new cap until it clicked and steam is still escaping, causing the temp to rise.
The reservoir isn't that old...options?
2001 Ford Taurus

Why did you replace the old cap?
The steam venting from the cap is just a symptom of the problem.
Um, sounds like the engine is overheating, -that's the likely problem.

First, start by making sure there's enough oil and coolant.

You don't want to over-fill the oil.
You CAN'T over fill coolant, you (over-filled radiator will expand and fill up the reservoir and then drip out the reservoir drain tube).

I'd start by topping off the oil, filling the radiator with water, then quick drive to get new antifreeze.
Changing the antifreeze, that should be a simple 1/2-hour-in-the-driveway job. Should be about 4 gallons of coolant, if you have tall enough ramps you might be able to use a 5 gallon bucket to drain the old coolant.
However, keep the drained coolant, let cool, then check for coolant color (should be light green, measure the volume, and look for oil mixed into the coolant.
 
  #11  
Old 04-14-19, 08:31 AM
A
Member
Join Date: Mar 2010
Location: USA
Posts: 4,109
Received 81 Votes on 75 Posts
Common reason for car overheating even with fan rotating normally and seemingly enough coolant in the system -- The thermostat is defective and stuck shut.

If you are not sure what the thermostat in the cooling system is, that thermostat is usually a disk like object in the coolant path perhaps visible right in the pipe opening in the coolant pump after the hoses are removed. It has no controls you can adjust. It may or may not be necessary to dismount the coolant pump to change the thermostat.

Don't forget, topping off the oil means only up to the full mark on the dipstick after pressing the latter all the way in and then pulling it out.
 
  #12  
Old 05-18-19, 01:26 AM
E
Member
Join Date: May 2019
Posts: 8
Received 0 Votes on 0 Posts
Any update?

Check that your coolant level is full. If you can open the radiator cap, verify it's level there as well. If not, just fill the reservoir to it's fill line.

Next, start the car, and go to the engine bay. Grasp the upper radiator hose (should be cold if you just started the car). You shouldn't feel any coolant flowing through it right after starting a cold car. The thermostat SHOULD be closed, thus not allowing coolant to flow through the upper hose yet. Squeeze it, you shouldn't feel any fluid moving inside of it. Now wait until the car is up to temperature (watch the gauge). Go back and feel the upper radiator hose again. You SHOULD feel coolant flowing through it now, and it should be warm. Now that the vehicle is up to operating temperature, the thermostat should have opened, letting coolant circulate through the whole system. If the hose remains cold, and you squeeze it and do not feel any fluid moving through it, your thermostat is stuck closed and it will need to be replaced. A stuck thermostat does not allow the fluid to circulate through the radiator and past the fans to be cooled, resulting in the coolant being "stuck" and overheating. If your temp gauge begins to rise to where it is getting too hot, and you still don't feel coolant circulating through the upper hose, the thermostat is definitely shut.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: