Troubleshooting 1990s Hot Spring Hot Tub


  #1  
Old 02-15-24, 06:57 PM
N
Member
Thread Starter
Join Date: Feb 2024
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
Troubleshooting 1990s Hot Spring Hot Tub

I purchased a 90s hot spring hot tub recently and just had our electrician hook the hot tub up. The light comes on and the pump is running water through the heater but we have been unable to get the jet motor to kick on. Iím not sure if it is a wiring issue on our end or something else electrically. He said something about a relay potentially but the previous owners had the hot tub running before us. Hereís picture of the electrical panel. Let me know what some potential issues are and what I can do to rectify the issue. Thank you so much!


 

Last edited by PJmax; 02-16-24 at 05:29 PM. Reason: added enlarged/labeled pic
  #2  
Old 02-16-24, 05:07 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,746
Received 4,117 Upvotes on 3,697 Posts
Welcome to the forums.

I can't find the model that uses that board.
Manuals are supplied based on year and model.
Watkins 71380 control board.

I don't see any power on your terminal 5.
There is a black motor cable there.... black, white, green.... what voltage is that motor ?

The boards are convertible from 120/240 to 240 only.
This is only one wiring method. (you must consult the owners manual)

Those silver clips are factory supplied jumper clips.
 

Last edited by PJmax; 02-16-24 at 06:00 PM.
  #3  
Old 02-17-24, 04:53 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 28,170
Received 2,272 Upvotes on 2,024 Posts
Do you know what model spa you have? Like Sovereign or something else?

What voltage are you using to power your spa 120 or 240?

Some of their spa's could be wired to work on 120v or 240v and it has to be wired accordingly for whichever you are using. One difference in operation is with 120v operation the heater is never on when the main jet pump is running. The 240v setup allows the heater and main pump to operate simultaneously.
 
  #4  
Old 02-19-24, 08:21 AM
N
Member
Thread Starter
Join Date: Feb 2024
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts

this is the model and serial number of the hot tub.
 
  #5  
Old 02-19-24, 08:29 AM
N
Member
Thread Starter
Join Date: Feb 2024
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
We are trying to make it a 240.

 

Last edited by PJmax; 02-19-24 at 10:58 AM. Reason: added close up of ID plate
  #6  
Old 02-19-24, 11:30 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,746
Received 4,117 Upvotes on 3,697 Posts
I'm still having a difficult time. Your ID tag has no year of mfg on it.
It's supposed to correspond to one letter in the serial number.
This is the manual I'm using... Sovereign IQ manual - pdf

What is that shiny black cable coming into the junction box bottom right.
Is that a motor...if yes... what voltage.
Or is it a 120v power cord.
Do you have jumpers on the right board ?

The conversion from 120v to 120/240v keeps the spa running on 120v and just the heater gets connected to 240v. The actual conversion show a 120v circuit and a 240v circuit.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: