Help installing Honywell T5


  #1  
Old 11-15-18, 03:37 AM
R
Member
Thread Starter
Join Date: Nov 2018
Posts: 3
Received 0 Votes on 0 Posts
Help installing Honywell T5

Name:  trane3.jpg
Views: 81
Size:  86.9 KBName:  Trane1.jpg
Views: 81
Size:  34.2 KBI currently have Trane Thermostats and would like to replace them with Honywell T5+ 's. My HVAC system uses split compressors and air handlers with Electric heat. I see I need to change cable to include a common C , no problem with that but I am trying to sort out the blue and yellow leads on current Trane Thermostat.Photos of Trane Thermostat and terminal block in handler attached
 
  #2  
Old 11-15-18, 08:58 AM
R
Member
Thread Starter
Join Date: Nov 2018
Posts: 3
Received 0 Votes on 0 Posts
Help installing Honywell T5

This is the missing photo of Trane terminal block. Trying to understand what the blue and yellow leads do

Name:  20181113_145818.jpg
Views: 63
Size:  28.2 KB
 

Last edited by PJmax; 11-15-18 at 02:09 PM. Reason: enlarged/enhanced picture
  #3  
Old 11-15-18, 03:02 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,522
Received 1,595 Votes on 1,470 Posts
Welcome to the forums,

Based on the stat end. Can't see the connections clearly on the air handler end.
I see a wire on O at the air handler that would suggest a heat pump system.

R - red - R
W - white - W
Y - yellow - Y1
Y2 - blue - Y2
G - green - G
 
  #4  
Old 11-20-18, 09:11 AM
R
Member
Thread Starter
Join Date: Nov 2018
Posts: 3
Received 0 Votes on 0 Posts
Thanks very much for the replyam trying to replace Trane thermostats with Honeywell T5's. Question:I understand the C,G,Y,W and R connections but on my Trane there is also a blue wire connected toterminal Y2 on the thermostat and going to terminal Y on the control board. The yellow wire goes terminal BK on control terminal. The yellow comes from Y on the Trane thermostat. There is a Y2 , unused, on the terminal board.Trying to understand what terminal BK is all about and why the yellow wire from Y on the Trane thermostat doesn't go to Y on the control board instead goes BK and Blue goes to Y.
Any Ideas?
 
  #5  
Old 11-20-18, 08:23 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,522
Received 1,595 Votes on 1,470 Posts
If you look at the thermostat wiring and the wiring at the terminal block. They don't match. The same exact type of wire is not at both ends. That means there is a splice somewhere you'll need to find.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: