How to troubleshoot Moen 7594EC Arbor with motionsense?

Reply

  #1  
Old 03-03-17, 09:01 PM
C
Member
Thread Starter
Join Date: Jul 2010
Location: USA
Posts: 953
Received 0 Votes on 0 Posts
How to troubleshoot Moen 7594EC Arbor with motionsense?

I just installed the Moen 7594EC Arbor With Motionsense One-Handle High Arc Pulldown Kitchen Faucet and nothing is working. No water when wave on top, in front, or turn the handle in any direction. The blue light do blink every so often though. What else do I need to check? The battery are all new, both water lines are open, and the handle is open.
 
Sponsored Links
  #2  
Old 03-04-17, 04:48 AM
Norm201's Avatar
Member
Join Date: Sep 2013
Location: United States
Posts: 9,184
Received 255 Votes on 229 Posts
Don't mean to insult your intelligence, but did you turn on the water at the main and/or at the isolation valves?
 
  #3  
Old 03-04-17, 04:53 AM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 9,029
Received 74 Votes on 67 Posts
Call Moen they usually are very helpful.
 
  #4  
Old 03-04-17, 06:44 AM
C
Member
Thread Starter
Join Date: Jul 2010
Location: USA
Posts: 953
Received 0 Votes on 0 Posts
Norm201, I doubting myself too so I double check and the water valves are tuned on. If I disconnect the battery plug for a couple of minutes and connect it back, I can hear the water rushing into the faucet underneath the sink but no water coming out of the faucet.
 
  #5  
Old 03-04-17, 07:43 AM
C
Member
Thread Starter
Join Date: Jul 2010
Location: USA
Posts: 953
Received 0 Votes on 0 Posts
Pugsl, installed last night and I believed Moen's phone support closed. They're not opening during the weekend either. I don't know why a national/international company like Moen would close on weekends for support.
 
  #6  
Old 03-04-17, 11:08 AM
Handyone's Avatar
Member
Join Date: Aug 2000
Location: U.S.
Posts: 5,450
Received 0 Votes on 0 Posts
Hey Charlie.
Here's a quote from Moen instructions, This is after unplugging the battery pack for 10 seconds:

Ensure that no people or objects are within 3 feet of
the faucet before startup. These could interfere with
the startup process. Wait 30 seconds for the faucet to
complete the startup process
The batteries must be alkaline, not rechargeable. Also check the cable from battery pack to faucet for damage/pinching and unplug it and plug it back it firmly.
 
  #7  
Old 03-05-17, 09:03 AM
C
Member
Thread Starter
Join Date: Jul 2010
Location: USA
Posts: 953
Received 0 Votes on 0 Posts
Thanks, Handyone for the response. If I unplugged the battery cable and plug it back, the water rush out for a second then it stops.
 
  #8  
Old 03-05-17, 03:22 PM
Handyone's Avatar
Member
Join Date: Aug 2000
Location: U.S.
Posts: 5,450
Received 0 Votes on 0 Posts
I'm at a loss. As Pugs said call the Moen help line. They will probably narrow it down real quick and either tell you what's wrong or send you a new unit. They are helpful.

The only reason I know of why the blue light would flash is because the faucet is not sensing any water connection.
 
  #9  
Old 03-05-17, 05:48 PM
C
Member
Thread Starter
Join Date: Jul 2010
Location: USA
Posts: 953
Received 0 Votes on 0 Posts
As I've said before, Mone's support is closed during the weekend. Yes, I will call them Monday when they're open. I was just troubleshooting the issue in the mean time.
 
  #10  
Old 09-03-17, 04:45 PM
C
Member
Join Date: Sep 2017
Location: Usa
Posts: 1
Received 0 Votes on 0 Posts
Fix?

charlie, exact same issue for me and of course it's the holiday weekend. Did you find a fix for this??
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: