My water smells since I added a whole house sediment filter

Reply

  #1  
Old 09-04-19, 07:45 PM
K
Member
Thread Starter
Join Date: Sep 2019
Posts: 1
Received 0 Votes on 0 Posts
My water smells since I added a whole house sediment filter

I added a whole house sediment filter this spring to get rid of the discoloration that was happening in my tubs and toilets. It worked great to remove the sediment and staining, but now within a few weeks of replacing the filter cartridge, my water starts to smell like rotten eggs. I do not recall my water having any odor issues before I added the filters.
i use carbon filters and replace them monthly, but the odor still appears and easily penetrates them. Also, when I remove the filters the odor is extremely pungent and a black film is left on the inside of the filter containers.
Any thoughts as to what is causing this and why it only started once I added the filter units.

Thanks.
 
  #2  
Old 09-04-19, 08:03 PM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Location: USA
Posts: 26,570
Received 787 Votes on 725 Posts
I'm not an expert in this field but it sounds to me like the filter is catching and concentrating large quantities of manganese and sulfur in your water. You probably need a different type of filtration system.
 
  #3  
Old 09-05-19, 05:17 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 24,433
Received 749 Votes on 688 Posts
The smell may have stared with the filter because those particles are being held for weeks at a time. Previously everything passed through your pipes and down the drain so it didn't stick around long enough to smell. Now you are trapping those particles and holding them in the filter for a month. A simple solution might be to change the filter more often. The better solution might be a different filtration system like XSleeper mentioned.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: